[BusyBox] Re: [BusyBox-cvs] svn commit: trunk/busybox: include networking

Shaun Jackman sjackman at gmail.com
Wed Jul 27 23:14:31 UTC 2005


On 7/27/05, Rob Landley <rob at landley.net> wrote:
> The prefix "ENABLED_" wouldn't be a bad replacement for "CONFIG_" (less subtle
> for something with different semantics).  The CONFIG_ version would be
> #ifdef/#ifndef, and the ENABLED_ version of the same symbol would be 0 or 1.
> 
> This way, we don't have to worry about stupid compilers allocating space for
> constants.
> 
> Comments?
> 
> Rob

The ENABLED_ prefix works for me, or alternatively remove the CONFIG_
prefix and use just the FEATURE_ prefix. Note that if #if xxx is used
instead of #ifdef xxx, then xxx may be defined to 0 and 1, and both
the preprocessor and dead code elminitation will work. I suspect
#ifdef is too ingrained to remove it entirely though.

Another possible prefix is DEFINED_ (or maybe just DEF_), as in #if
DEFINED_xxx or if(DEFINED_xxx).

Cheers,
Shaun



More information about the busybox mailing list